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Macros from Square One for PC
[bookmark: _Toc25768641]Macros – Free Trial!
If you already know that you definitely want to get started with macros then you can download a copy of the Macros from Square One worksheet, which will lead you through the first stages:
Mac: http://www.archivepub.co.uk/documents/MSO_Mac
PC: www.archivepub.co.uk/documents/MSO_PC 
However, if you’re nervous of the technical side of things and would value the chance to just have a go at using a few of the more popular macro tools, then you’ve come to the right place.
Very quickly, and with no real technical skill, you can load a dozen or so macros and immediately start to use them in your day-to-day work.
Let’s get started
All you have to do is put a file in a folder:
FTmacros file → STARTUP folder  =  16 ready-to-use macros

1) Here are the FTMacros files:
	http://www.archivepub.co.uk/documents/FTmacrosMac
	http://www.archivepub.co.uk/documents/FTmacrosPC
2) Where is Word’s STARTUP folder is on your computer?
This is the main technical hurdle, but for the majority of people, it will be fairly straightforward.
(To help Mac and PC users, we’ve used highlight colours to identify the instructions relating to your computer type, Mac and PC.)
Here are some disc addresses, to give you an idea of where to look:
On a Mac:
/Users/Paul/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word
On a PC:
C:\Users\Paul\AppData\Roaming\Microsoft\Word\STARTUP
Confusingly, the folder we need is either the Word folder inside the Startup folder, or the STARTUP folder inside the Word folder!
Let’s find that folder for our macro file!
Try the quick and easy method first, but if it fails, at the end of this document are two appendices:
[bookmark: _Hlk113168379]	Appendix 1 – Slow and steady method for Macs
	Appendix 2 – Slow and steady method for PCs
On a Mac:
1. Open Finder and click the magnifying glass icon in the top RH corner to open the Search box/field.
2. Type 'startup' in this field and then click Enter.
3. Under Search 'This Mac', look for the folder called Startup.
4. Click this folder, and you should see a subfolder called Word.
5. Click on this, to open it.
This is where the FTmacrosMac file needs to go, so put a copy of the FTmacrosMac file in it. When you next start up Word, your macros will be ready to use.

On a PC: Click the Microsoft key (or click on the Start icon on the task bar) and type: %appdata%
Click Enter, and then work your way down the file structure:
	Microsoft – Word – STARTUP
The folder will probably be empty, though it may contain a small number of files.
When you’ve found your STARTUP folder, put a copy of the FTmacrosPC file in it. When you next start up Word, your macros will be ready to use.


Your new macros and keystrokes
In case you’re not used to using keystrokes, we’ll explain in the instructions for each macro, but here is a summary.
For Macs each item below is Ctrl-Option-<letter/number>, e.g. GoogleFetch is Ctrl-Option-G.
For PCs each item below is Shift-Alt-<letter/number>, e.g. GoogleFetch is Shift-Alt-G.
	
Macro name
	Keystroke

	CapperMax
	M

	CapperMin
	N

	CaseThisWord
	C

	Comma
	,

	CountRemainder
	R

	CustomKeys
	K

	Dash
	- (hyphen)

	EmDashUnspaced
	=

	GoogleFetch
	G

	HyphenAlyse
	H

	HyphenSpaceWordCount
	/ (think of it as ?)

	NumberToText
	9

	Period
	.

	ProperNounAlyse
	P

	TrackOnOffVisible
	T

	TrackOnOffVisibleMac
	Y


‘But I’ve already got some of these macros’
Please don’t worry. They won’t clash because I’ve given each of them a slightly different name: e.g. CapperMaxFT, CapperMinFT, CaseThisWordFT, etc.
Where are all the macros?
If you want to see a list of the macros, to confirm they are all there, you can do one of the following, depending on your computer:
1) Select the View tab in the ribbon at the top of the document and clicking on the Macros icon.
[bookmark: myTempMark2]2) (On older Macs) On the Tools menu, go down to Macro and then click Macros.
3) Click ⌘-Fn-F8 or just ⌘-F8.
4) Click on the View tab, find the Macros icon (towards the far right)  and click on the Macros icon at the top of it (not the writing below the icon).
5) Click Alt-F8

The list should look something like this:
[image: Graphical user interface, text, application

Description automatically generated]


Practising your new macros
We’ll now give you instructions, plus a few exercises that you can try, to see how the macros operate.

Fetching internet information – GoogleFetch
GoogleFetch automates searching the internet. Try for yourself:
1.	In the sentence below, place the cursor in the word ‘Decentraland’. (GoogleFetch is smart enough to know you that want it to search for the entire word, even though you haven’t selected it.)
Ex: MANA is the cryptocurrency exclusive to Decentraland, one of several virtual worlds. 
2.	Press Ctrl-Option-G (or Shift-Alt-G), which means, hold down both the Ctrl key and the Option key at the same time, then press the letter G. (On a PC, it’s the same but with Shift and Alt and G.)
Notice how GoogleFetch replaces all these steps: (1) select the text you want to search, (2) copy it, (3) open your browser, (4) load Google, (5) paste the search term, and (6) click Enter to execute the search.
[bookmark: _Keyboard_shortcuts_–]Here are a few more to try:
Ex1: The prime minister travelled to Mackinac Island for the weekend. 
Ex2: Finish your taco with a spoonful of Mexican crema.
 Tip: When you want to look up more than one word, just select the words and then run the macro, but again, you don’t need to select accurately because GoogleFetch will author extend the selection to the nearest whole words.  
Ex3: Completed in 1925, Briarcliff housed an Aeolian organ and was often the site of organ and other musical recitals. 
Ex4: Henry Dreyfus designed the iconic Western Electric Model 500 telephone.

Using macros to speed up copyedits – CaseThisWord
Let’s learn about a macro that speeds up making copyedits. CaseThisWord changes the capitalization of a word. You can run it while you’re editing, for any word whose capitalization needs changing.
1.	In the exercises below, place the cursor inside the word whose capitalization needs to be changed.
2.	Press Ctrl-Option-C (hold down the Ctrl and Option keys and click the C key).
or	Press Shift-Alt-C (hold down the Shift and Alt keys and click the C key).
 Tip: Turn on Track Changes if you want to record the edits the macro makes. 
Ex1: He built his home immediately East of the original house.
Ex2: She travelled to south America to study some of its famous architecture.
 Tip: In the following examples, when you need to change the capitalization of more than one word in a row, you do not need to move the cursor. Just click the shortcut again – as many times as you need.
Ex3:  Frazier and Bodin were among the few Atlanta firms that designed in an Avant Garde style.
Ex4:  The designers created a handheld Personal Radiation Detector for law enforcement, fire rescue, and other emergency responders.

Another speed-editing macro – NumberToText
NumberToText converts a number (numeral) to text. Try it out for yourself.
1.	In the exercises below, place the cursor anywhere in front of the numeral to be changed (e.g. somewhere around the name ‘Charles Black’).

2.	Press Ctrl-Opt-9 i.e. hold down the Ctrl and Opt keys and click the 9 key (the ‘9’ is a useful mnemonic, i.e. a number. (On a PC, it’s the same but with Shift and Alt and 9.)
Ex1: Frazier’s professional relationship with Charles Black began 3 years after forming his architecture practice. 
Ex2: The evacuation time of the platform was found to be below 4 minutes and walking time to a point of safety to be below 6 minutes.
  Tip: The cursor does not have to be immediately adjacent to the numeral you want to change. The macro scans the upcoming text, jumping to the next numeral. 
Ex3: They spent the next 15 years contributing to the architectural character of this exclusive Buckhead neighbourhood. In all, they built 36 houses.
Ex4: The Peachtree elevation contained a similar arrangement as the Pallas Apartments, although much reduced in scale; 2 protruding bays created a recessed central bay and 2 end bays.

Using macros to check for consistency – ProperNounAlyse
The macros you’ve tried so far are meant to be used as you edit. ProperNounAlyse is meant to be used before you make any copyedits. It analyses an entire document for potential inconsistencies between proper nouns. 
[bookmark: _Hlk107388899]In a separate file, it generates a ‘Proper noun queries’ report which (1) lists words that could possibly be variant spellings of one another and (2) shows the frequency of each. It uses different coloured highlighting to help you link the pairs, because they are sometimes separated by being in strict alphabetical order (e.g. ‘Bath’ and ‘Both’*). You then review the report to see which might be actual mistakes. You could then add them to your style sheet and correct them in the text before you begin editing.
(*Sure, you know immediately that these are not variant spellings of a proper noun, but the computer sees them as spelling variation similar to ‘Anderson’ and ‘Andersen’; this is an example of computer–human teamwork.)
[image: Diagram

Description automatically generated]
To try out ProperNounAlyse, you need to supply your own document (or you could use this document!):
1.	Choose a new or recent project. Use the unedited text. Open the document and click Ctrl-Opt-P (or Shift-Alt-P). Examine the results in the report that the macro generates.
(We said you could use ProperNounAlyse on this instruction document, because we have seeded it with (im)proper nouns like Pual Beverly, Jenifer Yankopulos or Karem Coxe – with apologies to Karen Cox, Jennifer Yankopolus and Paul Beverley!)
 IMPORTANT: When you run ProperNounAlyse, and other similar analysis macros, you need to give the computer time to work. Do not touch your keyboard or mouse while the macro is working. Word may crash. (The same applies to the following macro, indeed to any WhateverAlyse macro.)

Using macros to check for consistency – HyphenAlyse
This macro analyses the text to find how often word pairs are hyphenated, or occur as two words or as a single word, for example: ‘run-off’, ‘run off’ and ‘runoff’, and it also picks up words separated by an en dash, e.g. ‘blue–green’.
Here’s a sample output:
	above-mentioned . . 2
	
	abovementioned . . 3
	

	afore-represented . . 1
	
	
	

	all-band . . 1
	all band . . 1
	
	

	art-methods . . 1
	
	
	

	attention-based . . 12
	attention based . . 19
	
	

	attention-guided . . 3
	attention guided . . 1
	
	

	attention-modulated . . 25
	
	
	

	band-pass . . 18
	band pass . . 1
	
	

	bell-like . . 1
	
	
	

	bell-shaped . . 6
	bell shaped . . 2
	
	

	between-coefficient . . 1
	
	
	

	binary-classification . . 1
	
	
	

	bit-stream . . 17
	
	bitstream . . 2
	

	block-based . . 28
	block based . . 1
	
	

	block-wise . . 1
	
	
	

	blue-green . . 2
	
	
	blue–green . . 4

	bold-faced . . 1
	
	
	

	bottom-left . . 1
	bottom left . . 1
	
	

	closely-packed . . 5
	closely packed . . 3
	
	

	contrast-based . . 1
	contrast based . . 4
	
	

	corner-based . . 1
	
	
	

	
	
	
	


[bookmark: myTempMark]Speedy changes to sentence breaks
There is a set of complementary macros for punctuating the breaks in sentences. Here are the different possibilities (please ignore whether the English is right or not!); the macro name is at the left of each line:
The text before: This is a sentence it has [not got] a break in it.
Period: This is a sentence. It has a break in it.
Comma: This is a sentence, it has a break in it.
Dash: This is a sentence – it has a break in it.
EmDashUnspaced: This is a sentence—it has a break in it.
To go from any of the above to any other, simply place the cursor in the word ‘sentence’ and click the relevant keystroke to run the chosen macro (use Ctrl-Opt or Shift-Alt):
	Macro name
	Keystroke

	Comma
	,

	Dash
	- (hyphen)

	EmDashUnspaced
	=

	Period
	.



Changing capitalisation of headings
Again, another pair of complementary macros... Click in the heading above and run CapperMax, and it will give you the following capitalisation:
Changing Capitalisation of Headings
Or you can use CapperMin if you want to go in the reverse direction.
Here are the keystrokes (use Ctrl-Opt or Shift-Alt):
	Macro name
	Keystroke

	CapperMax
	M

	CapperMin
	N



‘Am I nearly there yet?!’
If you’re in the middle of editing a big file and you wonder how much more there is of it, you can run CountRemainder, and you’ll get a window like this:
[image: Graphical user interface, text, application, chat or text message

Description automatically generated]
So this is telling me that of my 147.4 kword file, I’ve only got 47.3 kwords (47,300 words) left to edit, and that’s only 29% of the total. I’ve already edited 103,700 words. (Ctrl-Opt-R or Shift-Alt-R)

‘How often is this word-pair hyphenated?’
HyphenAlyse is great to give an overall analysis of hyphenation, but if as I’m reading I come to ‘bit-stream’ and I have the feeling I saw it earlier as ‘bitstream’, or even ‘bit–stream’, I just select either ‘bit-stream’ or ‘bit–stream’ and run HyphenSpaceWordCount, and it will show me the following.
(Ctrl-Opt-H or Shift-Alt-H)
[image: Graphical user interface, text

Description automatically generated]

‘Argh! I forgot to turn track changes back on!’
So you’re editing a text and you come to a section where you want to make a few changes that you don’t want to be tracked (for whatever reason). So you make the changes, and then carry on editing; after 5/10 minutes you realise that you forgot to switch track changes back on. Nooo!
As an alternative, you can switch track changes on and off with TrackOnOffVisible. What this does is to create a temporary yellow background which is your indicator that track changes is off. Not until you switch it back on does the yellow background disappear. (Ctrl-Opt-T or Shift-Alt-T)
On some Macs, the programming trick we’ve used for the yellow coloration doesn’t work, so if it doesn’t work on your computer then you’ll have to use TrackOnOffVisibleMac; it’s a little slower, but it has the same sort of effect. (Ctrl-Opt-Y)

Changing keyboard shortcuts to assigned to macros
If the keystrokes we’ve assigned to the different macros don’t work properly, you can change them by using the macro CustomKeys, as explained below.
As an example, let’s assign an alternative shortcut to GoogleFetch. 
1.	Click Ctrl-Opt-K (or Shift-Alt-K on a PC), and this window will appear:
[image: Graphical user interface, text, application, email

Description automatically generated]

2.	Under Categories on the left, Macros is selected, which is why the right-hand column is a list of your macros. 
[image: Graphical user interface, application

Description automatically generated]
3.	Click in the box on the right and select the macro for which you want to change the keyboard shortcut. For this example, select GoogleFetch.
[image: Graphical user interface, text, application

Description automatically generated]
4.	Think of a suitable keyboard shortcut to assign to the macro. Then click inside the Press new keyboard shortcut box and type your desired shortcut key combination. 
[bookmark: _Hlk106442614]•	4a. Does it say Currently assigned to: [unassigned]? If so, this means that the key combination is free to use. For instance, for the GoogleFetch example, press and hold down the Alt key and then click the G key. Notice how it shows that Alt-G is [unassigned].
[image: Graphical user interface, application, Word

Description automatically generated]
•	4b. If Currently assigned to: says something other than ‘[unassigned]’, it means that Word has already assigned your chosen keystroke to another function. In this example, Ctrl-G is already assigned to the EditGoTo function. You can still choose this shortcut if you want, but note that it will then no longer be available to run the other function. 
[image: Graphical user interface, application

Description automatically generated]
[bookmark: _Hlk102680131]5.	Once you have decided on a shortcut, remember to click Assign. This is easily overlooked. 
•	If you forget, the shortcut will not be assigned and you will have to go through these steps again.
•	For the GoogleFetch example, select Alt-G – or some other key combination, if you prefer.
[image: Graphical user interface, text, application

Description automatically generated]
6.	When you are finished assigning shortcuts, click the OK (Close) button to close the window. Now you’re ready to use your keyboard shortcut.


Appendix 1 – Slow and steady method for Macs
Below is the simple ‘recipe’, but first you need to ‘enable macros’. This is done in Word’s Trust Center.
Open a Word file and click on the Word menu. Select Preferences – Security. In the Macro Security section, click Enable all macros.
It may say something like ‘not recommended; potentially dangerous code can run’, but don’t worry, as soon as you’ve finished the recipe below, you can switch it back to Disable all macros without notification.
Now we can get started...
1. Open the FTMacros file, and then click on the View tab, find the Macros icon (towards the far right)  and click on the Macros icon at the top of it (not the writing below the icon).
2. In the Macros window that opens, you will see a list of macros; ignore these and just click the Edit button.
3. You will then see some computer code; ignore this because what we need is called the Immediate Window. If that is already visible (probably in the lower part of the screen), you can proceed to item 4.
Click the View menu at top of the screen and go down and click the Immediate Window item. 
4. In the Immediate window type (or copy) this:
	?Application.StartupPath
and press Enter.
5. Copy the computer address that then appears – this is the address of your STARTUP folder.
6. Now we need to get into that STARTUP folder (which will probably be empty for now), because we want to put a copy of the FTMacros file into that folder.
Click anywhere on your desktop – you should then see the word Finder at the top left. On the Go menu along the top, select Go to Folder. In the window that pops up, paste the address you just copied and press Enter. You are now in Word’s STARTUP folder. The folder will probably be empty.
7. Close the FTMacros file and put a copy of that file into the STARTUP folder.
8. Close this file you’re that reading now, and close any other open Word files, to ensure that Word closes down completely, then open MS Word again, open this file and be ready to...
9. Click on the View tab, find the Macros icon over to the right and again click on the icon itself, rather than the wording below it.
10. If all has gone according to plan, you should now have a list of over a dozen macros, ready to use.

Appendix 2 – Slow and steady method for PCs
Below is the simple ‘recipe’, but first you need to ‘enable macros’. This is done in Word’s Trust Center.
Open a Word file and then click the File tab, then go down and click Options, right at the very bottom.
Then, in Word Options, again at the bottom, click Trust Center.
In the window that appears, click Trust Center Settings..., and finally click Enable all macros.
It may say something like ‘not recommended; potentially dangerous code can run’, but don’t worry, as soon as you’ve finished the recipe below, you can switch it back to Disable all macros without notification.
Now we can get started...
1. Open the FTMacros file, and then click on the View tab, find the Macros icon (towards the far right)  and click on the Macros icon at the top of it (not the writing below the icon).
2. In the Macros window that opens, you will see a list of macros; ignore these and just click the Edit button.
3. You will then see some computer code; ignore this because what we need is called the Immediate Window. If that is already visible (probably in the lower part of the screen), you can proceed to item 4.
Click the View tab at the top of the Microsoft Visual Basic for Applications window, go down to Immediate Window and click on that.
4. In the Immediate window type (or copy) this:
	?Application.StartupPath
and press Enter.
5. Copy the computer address that then appears – this is the address of your STARTUP folder.
6. Now we need to get into that STARTUP folder (which will probably be empty for now), because we want to put a copy of the FTMacros file into that folder, so open a File Explorer window, click in the address line and paste in the address you just copied, and press Enter. You are now in the STARTUP folder, which will probably be empty.
7. Close the FTMacros file and put a copy of that file into the STARTUP folder.
8. Close this file you’re that reading now, and close any other open Word files, to ensure that Word closes down completely, then open MS Word again, open this file and be ready to...
9. Click on the View tab, find the Macros icon over to the right and again click on the icon itself, rather than the wording below it.
10. If all has gone according to plan, you should now have a list of over a dozen macros, ready to use.
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